default or selected kernelversion does not have config value CONFIG_ATM_HORIZON.
Result is shown for kernelversion 6.7.7

Madge Horizon [Ultra] (Collage PCI 25 and Collage PCI 155 Client)

modulename: horizon.ko

configname: CONFIG_ATM_HORIZON

Linux Kernel Configuration
└─>Device Drivers
└─>Network device support
└─>ATM drivers
└─>Madge Horizon [Ultra] (Collage PCI 25 and Collage PCI 155 Client)
In linux kernel since version 2.6.12  
This is a driver for the Horizon chipset ATM adapter cards once
produced by Madge Networks Ltd. Say Y (or M to compile as a module
named horizon) here if you have one of these cards.

source code: