default or selected kernelversion does not have config value CONFIG_GIGASET_CAPI.
Result is shown for kernelversion 6.7-rc3

Gigaset CAPI support

configname: CONFIG_GIGASET_CAPI

Linux Kernel Configuration
└─>Device Drivers
└─>ISDN support
└─>Siemens Gigaset support
└─>CAPI 2.0 subsystem
└─>CAPI 2.0 subsystem
└─>Gigaset CAPI support
In linux kernel since version 2.6.33 (release Date: 2010-02-24)  
Build the Gigaset driver as a CAPI 2.0 driver interfacing with
the Kernel CAPI subsystem. To use it with the old ISDN4Linux
subsystem you'll have to enable the capidrv glue driver.
(select ISDN_CAPI_CAPIDRV.)
Say N to build the old native ISDN4Linux variant.
If unsure, say Y.