default or selected kernelversion does not have config value CONFIG_NOUVEAU_LEGACY_CTX_SUPPORT.
Result is shown for kernelversion 6.7.7

Nouveau legacy context support

configname: CONFIG_NOUVEAU_LEGACY_CTX_SUPPORT

Linux Kernel Configuration
└─>Device Drivers
└─>Graphics support
└─>Nouveau legacy context support
In linux kernel since version 4.2 (release Date: 2015-08-30)  
There was a version of the nouveau DDX that relied on legacy
ctx ioctls not erroring out. But that was back in time a long
ways, so offer a way to disable it now. For uapi compat with
old nouveau ddx this should be on by default, but modern distros
should consider turning it off.