default or selected kernelversion does not have config value CONFIG_QCOM_ADSP_PIL.
Result is shown for kernelversion 6.8.9

Qualcomm ADSP Peripheral Image Loader

modulename: qcom_adsp_pil.ko

configname: CONFIG_QCOM_ADSP_PIL

Linux Kernel Configuration
└─>Device Drivers
└─>Remoteproc drivers
└─>Device Tree and Open Firmware support
└─>Qualcomm ADSP Peripheral Image Loader
In linux kernel since version 4.1 (release Date: 2015-06-21)  
Say y here to support the TrustZone based Peripherial Image Loader
for the Qualcomm ADSP remote processors.

source code: